كيفية استعمال دالة البحث الرأسي RechercheV

من طرف Abdo Ibdaanet  |  نشر في :  5:02 م 0 تعليقات

نتابع اليوم في سلسلة دروس اكسيل كيفية استعمال دالة البحث الرأسي RechercheV التي تمكننا من البحث عن معلومات باستعمال رقم معين مثلا.

لاحظ الجدول التالي:

جدول دالة البحث الرأسي


عندما ندخل رقم البطاقة الوطنية و نضغط على Entrée سيقوم اكسيل بعرض المعلومات الشخصية الموافقة للرقم الذي بحثنا به.

أين يبحث أكسيل؟


قبل أن نصل إلى هذه المرحلة، فإننا قمنا أولا بإنشاء قاعدة بيانات كما في الجدول التالي وأعطيناها اسم ListeClt

جدول قاعدة البيانات


وانطلاقا من هذا الجدول سيتم استدعاء المعلومات التي نريدها أثناء إجراء البحث بواسطة رقم البطاقة الوطنية.

كيف يتم تسمية قاعدة البيانات؟

قمنا أولا بتحديد جميع خلايا جدول قاعدة البيانات ثم في حيز اسم الخلية Zone de Nom كتبنا ListeClt كما في الصورة أعلاه،ثم قمنا بالضغط على الزر Entrée.

والغرض من ذلك هو تفادي الوقوع في خطأ أثناء استدعاء مراجع خلايا هذا الجدول لكتابتها في دالة البحث الرأسي RechercheV

إدراج دالة البحث الرأسي RechercheV

سنقوم أولا بإدراج دالة البحث الرأسي RechercheV في خلية الاسم و النسب:
بالنسبة للاسم نكتب
=RECHERCHEV($C$3;ListeClt;2;0)

$C$3 هو مرجع الخلية الخاصة برقم البطاقة الوطنية، وقد قمنا بتثبيته ليصير مرجعا مطلقا للخلية.

ListeClt هو اسم جدول قاعدة البيانات كما رأيت من قبل.

2 هو الرقم الترتيبي لخانة الاسم في قاعدة البيانات. بالنسبة لترتيب خانات قاعدة البيانات فإننا نقوم بالعد ابتداء من اليسار.

0 هذه القيمة تفرض على عملية البحث أن تعرض النتيجة بالضبط دون تحديد قيمة مجاورة لما نبحث عنه.

نموذج دالة البحث الرأسي RechercheV


عند الضغط على Entrée ستعرض النتيجة التالية : ( رقم البطاقة يجب أن يكون أولا مكتوبا في خلية رقم البطاقة الوطنية).

نتيجة دالة البحث الرأسي الأولى


قم بتغيير رقم البطاقة الوطنية و اضغط على Entrée ولا حظ النتيجة.

نسخ دالة البحث الرأسي في باقي الخلايا :

نقوم بنسخ ما كتبناه في خلية الاسم في باقي الخلايا مع استبدال الرقم الترتيبي الخاص بالخانات الموافقة لكل معطى نريد الحصول عليه.
لاحظ الصورة:

نسخ الدالة RechercheV في باقي الخلايا


بالنسبة لخلية الاسم و النسب سنقوم بكتابة دالة البحث الرأسي الخاصة بالنسب و نضيفها إلى دالة البحث الرأسي الخاصة بالاسم كما يلي باستعمال الرمز &

كتابة دالتي البحث الرأسي متجانبتين


قم إذن بتغييررقم البطاقة الوطنية و اضغط على Entrée ولا حظ النتيجة.

تابع معنا الفيديو التالي لمزيد من التوضيح:

ابـدأ نـت

دليلك في تعلم استعمال الكمبيوتر والأنترنت إذا أعجبك الموضوع، شاركه مع أصدقائك أو قم بتقييمه.

شارك الموضوع

مواضيع ذات صلة

0 التعليقات:

ابدأنت يشكرك على ترك تعليقك ويرحب بك على صفحاته.

انضم إلينا على اليوتوب



تابعنا على الفيسبوك

back to top