شرح دمج الدالتين Si و ET

من طرف Abdo Ibdaanet  |  نشر في :  8:59 م 0 تعليقات

تعرفنا على طريقة استعمال الدالة SI وأيضا الدالة ET، واليوم سنتابع كيفية دمج الدالتين معا في دالة واحدة و ذلك من خلال اعتمادنا على معطيات الجدول التالي كمثال توضيحي:


جدول المعطيات


دمج الدالتين SI و ET:


عند دمج الدالتين سيتم عرض نتيجة تستجيب لتحقق شروط معينة، وستكون النتيجة عبارة عن نص أو عدد أو غيره و ليست إما القيمة صحيح أو خطأ كما تابعنا في درس الدالتين ET و OU

فمن خلال الجدول أعلاه نريد تحديد تخفيض معين من قيمة المبلغ الإجمالي في حالة ما إذا كان الزبون تاجر جملة و مبلغ المشتريات يتجاوز 10 000 درهم.

نسبة التخفيض ستكون محددة في 2%.

وفي حالة كان الزبون تاجرا بالتقسيط  فلن يستفيد من أي تخفيض.

نكتب إذن في خانة التخفيض Remise الدالة التالية:

=SI(ET(B3="Grossiste";C3>10000);C3*2%;0)

كما تلاحظ، نبدأ أولا بإدراج الدالة SI وكما تابعت من قبل فإن أول شئ نحدده في الدالة SI هو شرط التحقق Test logique .

شرط التحقق هنا هو القيمة صحيح Vrai  في حال توفُر شرطي الدالة ET اللذين هما :

Grossiste: تاجر بالجملة.

C3>10000: المبلغ المالي يفوق 10 آلاف درهم.

وعندما تكون القيمة هي Vrai، يعني تحقق الشرط فإن اكسيل سيقوم بتطبيق العملية التالية:

مبلغ التخفيض = الثمن الإجمالي x 2%

وإذا كانت القيمة هي Faux فإن الدالة SI تعرض لنا النتيجة 0 درهم.

عند تطبيق الدالة نحصل على النتيجة التالية:



نتيجة دمج الدالتين Si و Et

ننسخ العملية في باقي الخلايا فنحصل على مايلي:


النتيجة العامة Si+Et


تابع معنا الفيديو التالي :

ابـدأ نـت

دليلك في تعلم استعمال الكمبيوتر والأنترنت إذا أعجبك الموضوع، شاركه مع أصدقائك أو قم بتقييمه.

شارك الموضوع

مواضيع ذات صلة

0 التعليقات:

ابدأنت يشكرك على ترك تعليقك ويرحب بك على صفحاته.

انضم إلينا على اليوتوب



تابعنا على الفيسبوك

back to top